Installation problem on Debian 5 with Nagios3 & Nconf

Support requests, bug reports, questions etc.
Installation problem on Debian 5 with Nagios3 & Nconf

Post by gpearce2408 » Tue Apr 28, 2009 15:24


have installed a clean copy of debian and nagios3, have installed nconf and all ok. Logged in for the first time and tried to generate a nagios conf and keep getting the same issue

Checking misc settings...
Error: Unable to write to check_result_path ('/var/lib/nagios3/spool/checkresults') - Permission denied

I know this is in the troubleshooting and I have followed all that, just cant get past this one error. Am I missing something. I have changed permissions, changed the user nothing that i have tried has worked.


User avatar
NConf developer
NConf developer
Joined:Fri Mar 06, 2009 17:50
Location:Zurich, Switzerland

Re: Installation problem on Debian 5 with Nagios3 & Nconf

Post by agargiulo » Tue Apr 28, 2009 16:23

Just to explain the exact source of the error: it's not really an NConf problem. The "Permission denied" message comes from your Nagios binary, which is trying to cache some data to its "checkresults" folder. This is a feature that was introduced with Nagios 3.
Try executing the Nagios binary with "-v" on the commandline, and you will get the exact same error, if you do it as your webserver user.


Code: Select all

    usermod -s /bin/bash www-data (give the user a shell)
    su - www-data
    /path/to/bin/nagios -v nconf/temp/test/Default_collector.cfg
    touch /var/lib/nagios3/spool/checkresults/testfile (try writing to folder)
Make sure not only the "checkresults" folder is accessible,
but that the webserver user also has access all upper-lying folders:

Since the "/var/lib/nagios" folder and all subfolders are owned by the group "nagios" by default, it might be the easiest if you simply add your webserver user to the "nagios" group.
Check out the complete thread here: