Installing NConf doesnt go past Step 1

Everything else...
Locked
lmc

Installing NConf doesnt go past Step 1

Post by lmc » Wed May 06, 2009 04:01

Hi all,

I currenlty have nconf v1.2.4-0 installed

My setup is as follows:
- Ubuntu 9.04
- Nagios 3.06
- apache2
- php5
- mysql 5.1.30 (my database name is NConf)
- perl 5.10

My problem: when accessing http://localhost/nconf/install.php I'm able to pass the requirements test (see below)
PHP 4.4 (or higher) -> 5.2.6-3ubuntu4.1 OK
MySQL 5.0.2 (or higher) -> 5.0.75 OK
Perl 5.6 (or higher) -> 5.10.0 OK

So I click Next, on the next screen I then enter my database connection details (Step 1 of the Quick Start Guide), I click Next and I get a "Checks" section appear but then nothing happens beyond that - no errors, nothing at all! What am I doing wrong?

I have checked the following:
- I have given my db user full access to NConf db -> this I have tested through mysql as I am able to see NConf table with my db user, I have even tried using root for the DB details of the nconf install but no luck
- I have given all users full access to /var/www/nconf (root is the owner of www folder)
- I have even tried manually modifying mysql.php and nconf.php, also copied config.original to confg (including hidden files)
- I have tried restarting apache2 after each change
- I have made sure php.ini file has mysql extension enabled and that extension_dir is pointing to the correct nagios bin location (nagios is installed under /usr/local/nagios)

I suspect its a permissions problem somewhere along the line? I appreciate your input as I am at a loss as to what else to do - thanks in advance!
-

User avatar
agargiulo
NConf developer
NConf developer
Posts: 725
Joined: Fri Mar 06, 2009 17:50
Location: Zurich, Switzerland
Contact:

Re: Installing NConf doesnt go past Step 1

Post by agargiulo » Wed May 06, 2009 12:00

Hi. Is InnoDB configured properly in your MySQL configuration? Is php-mysql installed? Is your /var/www/nconf/config dir writable to the apache user?

Try dropping the database, and recreating it once more. Maybe a previous installation created parts of the database and this is now causing conflicts.
If this doesn't help, try the full manual install as described in the README file. Maybe you will find the source of the problem during the manual install.

I hope this helps.
Regards,
Angelo

lmelvin
starter
starter
Posts: 4
Joined: Thu May 07, 2009 00:14

Re: Installing NConf doesnt go past Step 1

Post by lmelvin » Thu May 07, 2009 00:23

I have tripped over this as well; I had neglected to install php-mysql (and its prerequisite php-pdo) on my Red Hat Enterprise 5.3 (Tikanga) box. In my httpd error_log, I saw messages like this:

Code: Select all

[Wed May 06 15:55:04 2009] [error] [client 134.86.113.119] PHP Notice:  Undefined variable: step in /opt/nconf-1.2.4-0/include/menu/menu_install.php on line 20
Installing the needed RPMs and restarting httpd solved the issue.

Possibly consider adding php-mysql verification during preinstall check?

Lee

lmc

Re: Installing NConf doesnt go past Step 1

Post by lmc » Fri May 08, 2009 03:09

Thanks for the suggestions....

I installed php-mysql on Ubuntu with the folowing command: sudo apt-get install php5-mysql. Is this the same as running php-mysql on Redhat? Has anyone got NConf working on Ubuntu?

I even tried running through the manual config and get the same issue. Think I will start all over again and see how I go!

Just another question - how do I configure Innodb?? From my understanding it is already configured by default with mysql 5 install?

Thanks for the feedback!

User avatar
agargiulo
NConf developer
NConf developer
Posts: 725
Joined: Fri Mar 06, 2009 17:50
Location: Zurich, Switzerland
Contact:

Re: Installing NConf doesnt go past Step 1

Post by agargiulo » Fri May 08, 2009 10:31

Just another question - how do I configure Innodb?? From my understanding it is already configured by default with mysql 5 install?
This really depends on your OS distribution and the MySQL package you install. It is very well possible that InnoDB is already configured. I know that with RedHat/CentOS you can use the default settings, which are the following:

Under '/var/lib/mysql' InnoDB will create a 10MB datafile and two 5MB transaction logs:

Code: Select all

ls -l /var/lib/mysql/
-rw-rw----  1 mysql mysql 10485760 May  8 10:06 ibdata1
-rw-rw----  1 mysql mysql  5242880 May  8 10:06 ib_logfile0
-rw-rw----  1 mysql mysql  5242880 May  8 10:01 ib_logfile1

Locked