PHP errors - solved

Support requests, bug reports, questions etc.
Locked
Newling
PHP errors - solved

Post by Newling » Thu Apr 30, 2009 09:07

Hi,
i have set up a Opensuse 11.1 with all updates and PHP5-5.2.9.
Setup Apache, mysql, nagios and nconf.

After a lot of strange effects (not starting nconf, all errors listet in the troubleshooting)
i detected, that the actual PHP is not accepting PHP-code starting win the usual "<?"
All php scripts must have the "<?php" - or you will get very strange error-messages.
I've done this by, now i can delete services, hosts, etc.

regards to Swiss

Andi

User avatar
agargiulo
NConf developer
NConf developer
Posts:725
Joined:Fri Mar 06, 2009 17:50
Location:Zurich, Switzerland
Contact:

Re: PHP errors - solved

Post by agargiulo » Thu Apr 30, 2009 11:04

This issue has been fixed in NConf 1.2.5.

Work-around
Set the following option in your php.ini:

Code: Select all

short_open_tag = On
See the other requirements also:
http://apps.sourceforge.net/mediawiki/n ... quirements

Locked