Templates

Support requests, bug reports, questions etc.
Locked
JarekG
Templates

Post by JarekG » Tue Jun 09, 2009 17:03

Hi,

Do you know why when I change template for my host, services and other things related to that template are not updated ? For example I've created template windows with services such as ping, ftp, dns. Second template is linux with services pop, http, ping, dns, local_disk. By the mistake I set wrong template to the host and I want to change it. I do it but services are the same... is there any trick how to easily update it ?

It's exactly the same with services template. By default ping is set between 20,40% or something like that and when I've changed global command the local for each host hasn't been updated.

Thanks for your answers.

Regards,
Jarek

User avatar
agargiulo
NConf developer
NConf developer
Posts:725
Joined:Fri Mar 06, 2009 17:50
Location:Zurich, Switzerland
Contact:

Re: Templates

Post by agargiulo » Wed Jun 10, 2009 08:12

Hi.

Host-templates do two things:
- define the host-alive-check
- define the default services to be added to a host

While the host-alive-check is physically linked to the host over its template, the services themselves are not linked to the template. The template only suggests possible services for a host. This is a one-time thing when you add a host. If you modify the services in a template, the hosts which use the template will not be updated. Only new hosts will be affected by the change.
The same thing goes for default service parameters. These are predefined for each checkcommand and are set when a service is added. If you modify the default parameters later on, the services will not be updated automatically. Only new services you add will get your new default parameters.
This means that if you modify a host-template, the only thing that will be updated is the host-alive-check of a host.

For large changes, we suggest you use the "multi-modify" function. Also, in NConf 1.2.5 there is a possibility to clone a service to multiple hosts.

Hope this helps. I will add your question to the "troubleshooting" section.

Locked