Unsupported browser alert

User / Community contributed content: modifications, patches, extensions, modules, scripts etc.

Unsupported browser alert

Postby Tontonitch » Thu Dec 22, 2011 15:29

Hi,

I've quickly written a change to the Nconf gui head, giving an alert if the client browser is considered as unsupported. I've done that as I have some users loving to use the "corporate" browser, which is still IE 7.0. Might it be useful for someone :)

Screenshot of the alert in IE 7.0:
feature_unsupported_browser_alert.png
feature_unsupported_browser_alert.png (54.78 KiB) Viewed 4667 times


Attached the patch:


Currently, I've specified only IE 7.0 and IE 8.0 as unsupported browsers. If you want to had more browsers, complete the $not_supported_browser array in include/head.php.

BR,
Yannick
User avatar
Tontonitch
NConf addict
NConf addict
 
Posts: 254
Joined: Fri May 07, 2010 10:14
Location: Thionville, France

Re: Unsupported browser alert

Postby fgander » Thu Dec 22, 2011 23:50

Funny patch :) hehe

Nice, but yea I will hopefully have some time after x-mas to check the problems on these browsers, at least on IE8...

Cheers Fabian
F.G. - NConf developer
http://www.nconf.org
Image
Follow NConf on Twitter!
User avatar
fgander
NConf developer
NConf developer
 
Posts: 308
Joined: Mon Mar 16, 2009 14:23
Location: Bern, Switzerland

Re: Unsupported browser alert

Postby fgander » Wed Jan 04, 2012 02:24

Please test this fix, if that kills the bug:)
https://github.com/nconf/development/co ... c42bfefd43

Should at least also work on IE8 now...

Regards Fabian
F.G. - NConf developer
http://www.nconf.org
Image
Follow NConf on Twitter!
User avatar
fgander
NConf developer
NConf developer
 
Posts: 308
Joined: Mon Mar 16, 2009 14:23
Location: Bern, Switzerland

Re: Unsupported browser alert

Postby Tontonitch » Wed Jan 04, 2012 08:26

Applied your commit on my setup, seems that IE8 (8.0) is well supported now. I can do basic changes to the config and generate+deploy it without problem.
I will test it also on a old IE7 today.
Thanks for that fix!
Cheers,
Yannick
User avatar
Tontonitch
NConf addict
NConf addict
 
Posts: 254
Joined: Fri May 07, 2010 10:14
Location: Thionville, France

Re: Unsupported browser alert

Postby Tontonitch » Wed Jan 04, 2012 11:06

Tested on IE7: working ! :o
I can modify, generate and deploy a config. Using common Nconf gui functionnalities: everything ok.
That's great!
Thanks!
Yannick
User avatar
Tontonitch
NConf addict
NConf addict
 
Posts: 254
Joined: Fri May 07, 2010 10:14
Location: Thionville, France

Re: Unsupported browser alert

Postby fgander » Thu Jan 05, 2012 01:44

Ha great. And it was just a "," comma... tja...

Cheers :mrgreen:
F.G. - NConf developer
http://www.nconf.org
Image
Follow NConf on Twitter!
User avatar
fgander
NConf developer
NConf developer
 
Posts: 308
Joined: Mon Mar 16, 2009 14:23
Location: Bern, Switzerland


Return to Contributions

Who is online

Users browsing this forum: No registered users and 1 guest

cron