Issues generating config

Support requests, bug reports, questions etc.

Issues generating config

Postby GaWd » Sat Mar 31, 2012 20:27

Hello all!

I just installed and configured nconf. After a few hiccups, I have it up and running. Unfortunately I have an issue I don't seem to be able to remedy using the forums, here...


Error
Error accessing or executing Nagios / Icinga binary '/usr/local/nagios/bin/nagios'.
Cannot run the mandatory syntax check.

The bindir is correct: /usr/local/nagios/bin/nagios. I have tweaked with it and tweaked with it-to no avail. The nagios bin file is owned by nagios:nagios, but I see no mention of the ownership of this file needing to be modified.

Can I get some direction here? Thanks!

Oh, and I do want to direct some attention to the "hiccups" I experienced when installing. The Installation documents are sort of at odds with each other.

The install guide: http://www.nconf.org/dokuwiki/doku.php? ... stallation THe doc suggests that one go to the manual installation instructions for MySQL config. WHen one reads that document (section) http://www.nconf.org/dokuwiki/doku.php? ... ommandline , they are likely to continue following instructions for installation. If they do that, they will end up following steps 4, and 5. That creates a dead-stop error when running INSTALL.php, because the INSTALL or UPDATE files exist.

I see another user ran into the same issue, and opened a thread in the installation problems section of the forum for the same problem.
GaWd
starter
starter
 
Posts: 3
Joined: Sat Mar 31, 2012 20:15

Re: Issues generating config

Postby scrat » Sun Apr 01, 2012 15:51

Hi,

Please check if your webserver user has read and execute permissions on /usr/local/nagios/bin/nagios.
Do you have a Linux distribution with enabled SELinux?
If yes, you have to change some SELinux contents to allow apache execute the Nagios binary.


Regards,
Rene
User avatar
scrat
NConf enthusiast
NConf enthusiast
 
Posts: 101
Joined: Mon Aug 23, 2010 16:28
Location: Vienna, Austria

Re: Issues generating config

Postby GaWd » Sun Apr 01, 2012 17:09

Thanks Rene. Took a little permissions tweak and all was good.
GaWd
starter
starter
 
Posts: 3
Joined: Sat Mar 31, 2012 20:15


Return to Support (NConf 1.3.0)

Who is online

Users browsing this forum: No registered users and 2 guests

cron