[SOLVED] no services/hosts defined after import

Support requests, bug reports, questions etc.
cookerino
starter
starter
Posts: 2
Joined: Mon Jan 02, 2012 12:33

[SOLVED] no services/hosts defined after import

Post by cookerino » Mon Jan 02, 2012 13:03

Hello

I just installed nconf 1.3.0 and started to import my existing Nagios configs as it is discriped here:
http://www.nconf.org/dokuwiki/doku.php? ... ort_nagios

The problem now is that after running the "Generate Nagios Config process" the following massage appears

Code: Select all

Nagios 3.0.6
Copyright (c) 1999-2008 Ethan Galstad (http://www.nagios.org)
Last Modified: 12-01-2008
License: GPL

Reading configuration data...

Running pre-flight check on configuration data...

Checking services...
Error: There are no services defined!
Checked 0 services.
Checking hosts...
Error: There are no hosts defined!
Checked 0 hosts.
Checking host groups...
Checked 0 host groups.
Checking service groups...
Checked 0 service groups.
Checking contacts...
Checked 2 contacts.
Checking contact groups...
Checked 1 contact groups.
Checking service escalations...
Checked 0 service escalations.
Checking service dependencies...
Checked 0 service dependencies.
Checking host escalations...
Checked 0 host escalations.
Checking host dependencies...
Checked 0 host dependencies.
Checking commands...
Checked 45 commands.
Checking time periods...
Checked 3 time periods.
Checking for circular paths between hosts...
Checking for circular host and service dependencies...
Checking global event handlers...
Checking obsessive compulsive processor commands...
Checking misc settings...

Total Warnings: 0
Total Errors: 2

***> One or more problems was encountered while running the pre-flight check...

Check your configuration file(s) to ensure that they contain valid
directives and data defintions. If you are upgrading from a previous
version of Nagios, you should be aware that some variables/definitions
may have been removed or modified in this version. Make sure to read
the HTML documentation regarding the config files, as well as the
'Whats New' section to find out what has changed.

I don´t know what to do now because the hosts show up in the web-gui so everything looks fine to me.
The commands and contacts seem to work ... butt everything else isn´t there...

Has someone a hint where the Problem could be ?

Thanks
(and Happy new Year to all )
Last edited by cookerino on Thu Jan 05, 2012 10:29, edited 1 time in total.

cookerino
starter
starter
Posts: 2
Joined: Mon Jan 02, 2012 12:33

Re: no services/hosts defined after import

Post by cookerino » Thu Jan 05, 2012 10:28

Hello,

I just missed to set the "monitored by" option.

Regards,
Cookerino

Locked