nconf not returning results for hosts and services

Support requests, bug reports, questions etc.

nconf not returning results for hosts and services

Postby wej-temp » Thu Sep 24, 2015 20:04

So recently we deleted a contact & contact group for one of our original users of our Nagios instance that no longer requires notifications. After that happened, nconf no longer shows any hosts when clicking Hosts or any services when clicking Services. If I go to "Show host parent/child relationships" I can still see all my hosts. When trying to generate a nagios configuration file, I am getting the following error:

Error: Cannot open main configuration file '/srv/www/htdocs/nconf/temp/test/AISO.cfg' for reading!

There is nothing in that directory to read from, which is why it's throwing the error. It seems like nconf is no longer writing the files out to the temp directory. The permissions are the same, and the web user has permission to write to that directory. I'm wondering why deleting a contact and contact group would cause this all to happen. Sadly, I don't have a backup of the mysql database, so I can't just restore from that. I need to figure out some other way to get nconf back up and running.
wej-temp
 

Re: nconf not returning results for hosts and services

Postby wej » Thu Sep 24, 2015 20:18

Well, I figured out how to turn on debugging in nconf and found an error from mysql. Apparently, even though I could connect and use mysql with the workbench, it was having difficulties accepting php connections. A quick restart of mysql resolved this issue.
wej
starter
starter
 
Posts: 1
Joined: Thu Sep 24, 2015 19:54


Return to Support (NConf 1.3.0)

Who is online

Users browsing this forum: No registered users and 2 guests

cron