Issues generating icinga configs

Support requests, bug reports, questions etc.

Issues generating icinga configs

Postby terrypewing » Wed Oct 16, 2013 21:22

Hello,


I'm having an issue with nconf 1.3.0 when using Icinga and I'm stumped on how to work around the issue. Hoping for some pointers so I don't pull any more hair out.

When I generate the config files I'm getting the following error:
Error: Service description, host name, or check command is NULL
Error: Could not register service (config file '/var/www/nconf/temp/collector_2/advanced_services.cfg', starting on line 93)
Error processing object config files!

I have unpacked the tarfile in the output directory and I can see the issue. The advanced service defined here is not used by any of the hosts monitored by collector_2. The error goes away if I use a host to check this advanced service.

This issue doesn't happen if I swap out icinga for Nagios3. The nagios3 engine is able to validate the config files just fine for any unused advanced services.

Thank you,
-Terry
terrypewing
starter
starter
 
Posts: 3
Joined: Wed Sep 18, 2013 21:38

Re: Issues generating icinga configs

Postby terrypewing » Sat Oct 19, 2013 01:50

Following up to my own post:

There is a bug report and a patch available. I've verified the patch fixed my issues.
viewtopic.php?f=17&t=872#p3028


Thanks,
-Terry
terrypewing
starter
starter
 
Posts: 3
Joined: Wed Sep 18, 2013 21:38


Return to Support (NConf 1.3.0)

Who is online

Users browsing this forum: No registered users and 1 guest

cron