Problem With Service Template

Support requests, bug reports, questions etc.
Locked
karldavidson
starter
starter
Posts: 4
Joined: Wed Oct 12, 2011 23:24

Problem With Service Template

Post by karldavidson » Fri Oct 28, 2011 01:11

Greetings,

I am having a rather critical problem with my service template. I have all of my services on one template so far, no parent templates. If I make a change to something such as "max check attempts" it is not taking when I generate configs and reload.

If I grep all of my configs for "max_check_attempts" I see every service running on the wrong value. The only place the grep shows the right value is on my service template. On each service (in the config) I see that only one service template is being assigned where it lists "use Main-Template"

I have no problem at all adding hosts and services, changing thresholds etc.

Can anyone help?

Thanks

Oliver Lamm

Re: Problem With Service Template

Post by Oliver Lamm » Fri Oct 28, 2011 12:08

Hi,

having the same problem. I have two templates to enable/disable notifications.
Version used: 1.2.6-1

Oli

User avatar
Tontonitch
NConf addict
NConf addict
Posts: 254
Joined: Fri May 07, 2010 10:14
Location: Thionville, France
Contact:

Re: Problem With Service Template

Post by Tontonitch » Fri Oct 28, 2011 12:22

Hi guys,
check your timeperiod definitions.
indeed, there are some attributes defined in the timeperiod definitions which can overwrite what you defined in the templates/services, such as "max check attempts". That could be your problem. Personnaly, I have removed all except the period definitions from the timeperiods.
Regards,
Yannick

karldavidson
starter
starter
Posts: 4
Joined: Wed Oct 12, 2011 23:24

Re: Problem With Service Template

Post by karldavidson » Fri Oct 28, 2011 18:46

That was it for me. Those options were specified in the 24/7 time period. I just cleared them out, and now the options are being taken from the service template. Everything is working beautifully.


Thanks Yannick

Locked